jQuery 2.0 bez obsługi starszych wersji IE

Twórcy popularnej biblioteki programistycznej JavaScript, jQuery, zapowiedzieli zaprzestanie wsparcia dla wszystkich wersji programu Internet Explorer sprzed IE 9 wraz z wydaniem jQuery 2.0 na początku 2013 roku. Decyzję zespół tłumaczy tym, że wsparcie dla starszych wersji przeglądarki koliduje z planem rozwoju funkcji przewidzianych dla biblioteki w przyszłości.

Deweloperzy planują rozpocząć usuwanie wsparcia dla starszych wersji IE już w wydaniu jQuery 1.8, które powinno się ukazać w ciągu miesiąca. Początkowo, interfejsy specyficzne dla IE pozostaną bez zmian.

Wersja jQuery 1.9 ukaże się prawdopodobnie na początku przyszłego roku: wraz z wydaniem usunięte zostaną przestarzałe funkcje, jednak użytkownicy będą mogli skorzystać z opcjonalnych wtyczek i alternatywnego API dla większości z nich. Ostatecznie, wydanie jQuery 2.0 – planowane jest niedługo po wersji 1.9 – „dwójka” porzuci wsparcie wcześniejszych wersji IE.

Dla użytkowników projektu oznacza to, że jeśli potrzebują wsparcia dla programu Internet Explorer 6, 7 i 8 na swoich stronach internetowych, będą musieli zostać przy jQuery 1.9. Chociaż ideą, która przyświecała twórcom jQuery była chęć zniwelowania różnic we wszystkich przeglądarkach, zespół stwierdza, że „starsze wersje IE były solą w oku programistów internetowych przez dekadę”. Choć deweloperzy nie chcą ignorować użytkowników przeglądarki IE, utrzymanie wsparcia dla starszych wersji IE najwyraźniej przerasta wszystkie inne problemy (sic!).

Źródło: Heise

Podziel się:
  • Wykop
  • Twitter
  • Gwar
  • Digg
  • Google Bookmarks
  • MySpace
  • del.icio.us
  • Facebook
  • RSS

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *